Results 1 to 2 of 2
  1. #1
    Super Moderator
    Join Date
    Oct 2016
    Location
    Dublin
    Posts
    114

    Attention: Mozilla Firefox players.

    Hello,

    Starting the 7th of March of 2017, Mozilla will drop support for all NPAPI plug-ins in Firefox 52, making Kings of the Realm Unplayable in this browser.

    This will only occur if you upgrade to Firefox 52.

    We are aware that some of our players will be affected by this and we are currently working on finding a solution.
    At present Safari still runs Kings of the Realm (Safari for Windows users may encounter some display issues at higher resolutions, these are fixed by full screening the game).
    And as always, the game is available on iOS, Android and Windows 8/10 store.


    We apologize for any inconvenience this may cause and will keep you updated on any progress we make addressing the issue.
    Solapaine - Community Manager
    twitter.com/CM_Solapaine

  2. #2
    Senior Member
    Join Date
    Apr 2015
    Location
    Murica
    Posts
    214
    Rip

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •